No more compound glyphs


A very valuable function has suddenly stopped functioning. When adding glyphs normally built from components (e.g. adieresis, beh-ar) the components of these glyphs are not automatically added as before, but have to be added manually. I’ve also tried using ‘Make Component Glyph’ from within the glyph without any result.

I’ve tried with ongoing projects, new fonts, various alphabets: same result.

Did I change a setting somewhere by mistake? Just days ago, everything worked just fine.

Thank you!


What has changed is that all the component glyphs must be in the font already. So if you want to ‘Make Component Glyph’ an adieresis, both the a and the dieresis must exist in the font already. In earlier versions, it would insert a reference to a ‘Missing Base Glyph’.

Ah, well that explains it. Thank you!

The Arabic tutorial needs to be updated to reflect this; it took me a while to realise why the instructions given there did not seem to be working at all.

1 Like