Noodler will not work as custom parameter, only as filter

Hello everyone, I’m sort of new to this so please excuse my ignorance.
I have been struggling to export a monoline font with glyphs recently. After following lots of instructions here and via email with support, I decided to create a file from scratch with 3 glyphs only (basic shapes) and test it.
It seems like the file will only exports if I apply noodler as a filter. When I apply it as a custom parameter in instances, nothing happens, I export and get the spinning wheel for ever.
I’m applying the following:
Property: Filter
Value: Noodler; 1; 1; 1

What am I possibly doing wrong? I’m on version Version 2.6.6 (1352) on a Mac OS Big Sur 11.2
I’d really appreciate your help with this.

UPDATE: a colleague of mine created the same file, same values, and was able to export perfectly with custom parameters. I’ve looked into the modules I have, all 3 seem to be installed, nothing else differs.Could I be needed an extra plugin or script?

There must be error messages either in Window > Macro Panel or in (search for ‘Noodler’).

Maco Panel has the grey line
# type your Python code here and press cmd+Return to run.

and console isnt returning anything for Noodler
Maybe because there’s no error message on glyphs? just the endless spinning?

Then it gets caught up in a task, probably in a specific glyph Consider:

  • disabling subroutines,
  • disabling hinting,
  • testing it with a smaller font, or a single glyph (by adding ; include: A at the end of the parameter value)

I suspect that it is a few complex glyphs that simply take a long time. See the Complex Outlines tutorial.

Thank you for this:
1 - tried disabling subroutine in instance, issue persists
2- hinting is already disabled
3- the font is only 1 character (A) for testing. The A has 3 nodes.
When I apply the noodler as a filter, it takes less than a second to export, just to put it in context. When I use custom parameter, even if I let it run for a couple of hours, nothing happens it gets stuck on the exporting font window with the wheel. I already uninstalled / reinstalled both glyphs and noodler. Not sure what else I can do…

It works for me a expected in versions 3.0.3 (3061) and 2.6.7 (1354) on Catalina. Can you send me your .glyphs file? I suspect there is something wrong with the setup.

Of course attaching it here. But it will probably work fine with you, just like my colleague was able to export no problem. I’m also attaching my settings / app preferences for you in case you need them.
Thanks so much for helping with this!
PS: I’m on Big Sur 11.2

all settings.pdf (1.3 MB) test4.glyphs (19.3 KB)

You did install all necessary modules? Perhaps check for an error message in when you try to export.

I installed Brew first, then the modules via Glyphs preferences (vanilla, robofab, font tools + mekkablue). Should I have anything else on there?
Nothing happens in console as the wheel spins.
Any other suggestions? It worked on yours I assume?

Can you export again and send me the resulting OTF?

Which hardware? Mac with an M1 chipset?

No, that should do. You do not need Homebrew though.

It works exactly as expected.

I don’t have any exports unfortunately, the problem is that when I use custom parameters, i get the export window indefinitely (the spinning export popup). I even let it run overnight and nothing happened.
I’m on MacBook Pro (16-inch, 2019) (no M1 Chip)
2.6 GHz 6-Core Intel Core i7
16 GB 2667 MHz DDR4

I’ve already uninstalled glyphs 2 and noodler and reinstalled both. Is there any other way to start this from scratch?

Please get in touch via DM, and schedule for a screensharing session.