Not all glyphs show up in Source Han Sans

For some reason, some Chinese glyphs do not show up when I open Source Han Sans (https://github.com/adobe-fonts/source-han-sans).
image

Which one exactly did you try?

Both the Simplified Chinese and Japanese Language-specific OTFs and the OTC had the same issue.

Note that the sidebar is based on glyph names, specifically the nice glyph names used during development (which may be different than the production names). When loading in a compiled OTF, the glyph names used are the production names in the font and File > Font Info > Other Settings > Use Custom Naming will be set.

If you’re trying to match using the sidebar, then try the following:

  • uncheck that Use Custom Naming setting,
  • In Font View, select all glyphs.
  • Choose the menu Glyph > Update Glyph Info to reset the glyph names, Unicode values.

More info is in the Import Existing Fonts and Getting Your Glyph Names Right tutorials.

Note that I have not looked at the Source Han Sans fonts. These are general notes for when importing an OTF. Hope that helps.

If there might be a different issue here, providing detail in what you did, see, and what you expected to see can help determine the issue.

I just tried following those steps and it didn’t solve the issue (certain Chinese character glyphs missing). For example, a basic character 八 (uni516B) does not show up, even under ‘All.’

For example, under Educational 1 only 37/80 characters are shown here, but there should be 80/80 with no missing glyphs.

I had a look at this and it works much better now.

Did you update the app? I tried re-downloading and the issue is still there.

No, will upload a new version in the next few days.

1 Like