Not Def/Tofu showing in MS Office font list

Hello. I am working on a font, when installed on Windows and used in Office (word etc) next to the font names in the font list there are these .notdef boxes.

Does anyone know why they would be appearing? They are not in the font names, nor is there any extra spaces in the name. Also do not show in Adobe suite / Apple apps.

Photo below.

That are some sample characters. Maybe you set some wrong bits in the Unicode ranges or codepage settings?

Related to this:
.notdef appearing in font menu (Windows 10) - #4 by lettersfromswe
I’ll reply here also:

I have a solution for this! Nobody seem to know why this happens, but I did som trial and error and for me it was the fact that we normally add 2–4 Greek glyphs to our fonts.

For some reason, Office seem to think that the font now support Greek, but decides to let me know it does not support full Greek, so therefor displays the .notdef like that in the menu. Stupid, I know. Office is.