Not found? what does this mean when importing shapes

The glyph "a chinese word " ws Not found
The font name is correct after import, the unicode is also correct, anything wrong?

When you try to drag an image into the font view, but not on a glyph cell, it tries to find glyphs with the name of the image files and lets you add them if they are not present, yet.

understood, thanks

please take a look at this pic, if I rename a svg as “a.svg” it will be imported to the position of letter “a”. But, if I don’t rename it and import it, it will be imported as a second glyph, so that there will be two words. For one unicode, there should be only one word to match it. On the picture blow there are two words for uni661B.
svg files uploaded for your test. the Chinese word is 愛
屏幕快照 2021-09-06 下午10.24.19 归档.zip (8.4 KB)

when exporting it will say "illegal character"

I think when importing, it should be placed on the position of the Unicode instead of creating a second cell and have no code assigned to it.

Svg file with a English name works fine, but for Chinese, it’s not working.

You need to use ‘uni611B.svg’ as name for the file. I’m working on the import to improve all this.

Thanks for your hard work.
For now, you are right, While, in the cell, apparently its unicode is recognized.
It works for english, it should also work for other languages.

any progress? Or the problem will be solved in the next release?

That will be in the next release.


when will the next cutting edge version come?

I’m almost there. I like to fix one more bug.

i downloaded the new version, importing Chinese words is still not resolved. I still have to rename it to unicode before importing. That would be boring job.

hello ?

You are right. I was working in a branch of the code for the next little bigger update and forgot to back-port this to the current code. Will be in the next update.

when will the next release come, i’ve been waiting for this for a long time. thanks.


Have you tried the latest cutting edge release, 3.0.4 (3100)? I believe that fix may be included there.

thank you for your great work. it’s included.
well, the position is not imported as designed. Chinese words should be centered in a square (even the template is not centered) .How to solve this, pls?
In fontforge, after importing, the position is correct. While, in this APP, i dont’ know how to change anything to make sure that all glyphs are correctly imported.

This will be better in the next (free) bigger update that we are preparing right now. It needed to many changes that I liked to add right now.

Thank you very much. This is a very basic function (position imported as designed and words in the APP template should be centered) for stroke based words. Without this function, we will have to import svgs to fontforge first , then save it to a font file, and edit the file in Glyphs App afterwards. That will be very boring.