.notdef appearing in font menu (Windows 10)

I was testing a font in Windows 10 and realized that in the menu the name shows .notdef.
I checked the name table and everything seems fine. Does someone had this happening before or know how to address this?

Captura de Pantalla 2022-11-28 a la(s) 3.03.15 p. m.

This is a representation of the currently selected word in Word.

It doesn’t happen with other installed fonts, though.

I have a solution for this! Nobody seem to know why this happens, but I did som trial and error and for me it was the fact that we normally add 2–4 Greek glyphs to our fonts.

For some reason, Office seem to think that the font now support Greek, but decides to let me know it does not support full Greek, so therefor displays the .notdef like that in the menu. Stupid, I know. Office is.

2 Likes

YES! Thanks a lot for finding this and sharing it :pray:t2:

I haver cracked quite many Office-related font issues, I should be hired by Microsoft as their expert consultant for modern Type designers.

One which is really handy is how to make kerning work in Powerpoint.

  1. Make sure you have no glyphs without unicode value in that have kerning pairs.
  2. Export the TTF with the “Export Kern Table” custom parameter. Here you also need to limit the kerning pairs to the number it says, so expect to sit and remove all smaller kerning pairs the font have for an hour or so, if you are a fine-tune-kerning kind of guy.
  3. It basically should work now – but does NOT (haha) so the TTF-font has to opened up in FontLab and then exported again, this last thing is a problem with Glyphs.

And if a PC-client want to avoid people pressing the Bold-button:

Export the font and say that the very same font you are exporting is also the “Bold” style linked to itself (it works on PC, not on Mac).

Last but not least, never try name a font with a name that has the three letters “NOR” in a row like that. Doing so will make Office think it’s the normal style, so it basically messes upp the weights, and display the wrong ones. Really weird issue, it took almost a week to figure this one out. Have tried to report this to Microsoft, but ignore me everytime I try to get some kind of support or have questions, I guess they just want everybody to use Calibri.

2 Likes