Offset Curve Filter and shapes

Hi everyone, I’m a bit new to Glyphs and am currently having some issues with the offset curve filter.

I followed the Monoline Font Tutorial to correct all of my open paths, which worked wonderfully, but it did not work for the closed paths I also had. Those are now just outlined and no longer filled in when I exported them out as a ttf. Any suggestions?


(Here is the tutorial I followed, specifically the Offset Curve Filter portion)

You need an exclude argument with the offer curve filter.

Oh okay! What would be the best way to go about completing that?

Read this:

Thank you! I am still a little unsure on what exactly I need to exclude.


Add the exclude part to the end of the first filter.

Got it! What goes after exclude: ?

The glyph named that should not be offsetted. If you need to exclude only parts of some glyphs, you need to fiddle around with components and Prefilters.

Ohhhh okay. How would I access those?

Thank you for helping out so much.

if you like to not offset some parts of the glyphs, you need to make an extra glyphs that only contains this part and place it as a component. And use a “PreFilter” instead of the “Filter” in your custom parameters.

So I attempted everything that you previously mentioned. I’m very new to Glyphs so I have attached quite a few photos so you can see what I’m getting! I chose to work on the H first.

First up here is a sketch, so you can see what I am aiming for.

I then created a component named HH, as pictured below.

The component was added to the original H, and all was removed except for what I wanted the offset filter to apply to.

The filter was pasted into the custom parameter, and the PreFilter/exclude part was added.

However, it looks like this when exported out. It is still not properly filling in the shapes from the component.

Being new to this, I’m sure I’m doing something wrong :slight_smile: Thanks!

You first say that you put it in “HH” but the exclude has a “_HH”?

Oh yes! My bad, I thought there had to be an _. I corrected that and this is what is now displaying.

I went ahead and updated the component HH, and followed the same process for I and J. Both of those seem to work great! The H is the only one that I cannot seem to get right.
Here are the H images, and the instances I currently have.

Please let me know if the I and J look correct, I can continue to play around with the H if needed. Thanks again!

1 Like

Which is HH and which is H?
Or maybe I don’t quite get it, what exactly is your question now?

I just want to make sure that everything looks correct. HH is the component I used for the letter H.

I wanted to know which of the pictures show HH. But I think I got it, the closed paths have a wrong path direction. Select all glyphs and choose Paths > Correct Path Direction.

I followed your instructions and unfortunately did not see a change.

I also tested this same process on A through J and all are displaying this way:

Can you please send me the .glyphs file to support (at) (this website without www). I will have a look.

Will do!

Have you received the file?