Offset curve: instance as master

Hi everyone!

Im trying to use an Outline instance made by Offset Curve Custom Parameter as a master. I need to make some adjustments and use the diacritics from the solid master (without outlines).

When I use “Instance as Master” in the Exports panel in Font Info it creates a master with empty glyphs.

How should I proceed? Is there any solution?


Can you try the latest cutting edge version? (Activate it in Preferences > Updates)

But you can configure the export filter to not outline the marks. Depending what else you need to adjust?

Nothing has changed with the latest cutting edge version.

I need to adjust some shapes that I don’t need to make outline.

The thin strokes of comma and Q for example.

Thank you.

As Georg suggested, you can try excluding those glyphs from the filter. Read more on the syntax here:

I think this can solve the combining marks and punctuation. But In some glyps as comma, Q, and some symbols I need some shapes outlined and some shapes without online.

Thaks for locating this resource in Hanbook!

My suggestion would be to compose those glyphs from components.

For example, build your Bitcoin from _B.currency (or B, depending on your design) and _bitcoin.bars Then set the _bitcoin.bars to be excluded from your filter.

Don’t hesitate to ask if you need guidance how to set up your components.

Should I create components for every glyph in this situation? Should I create special components for “at”, copyright, “paragraph”…?

The only glyph I’m not sure if can solve with this solution is comma. I can create a component with the “tail” but it will be hard to match perfect with the corner in the solid and outline style.

Maybe I can create al alternate glyph for comma and use it only in outline instance.
Is it possible to make something similar to dollar but just with one master and two instances (solid and outline)?

With this custom parameter I mean:

Thanks a lot!

I see your problem. In that case, I would indeed suggest creating an alternate comma.

Make a comma.outline, draw it how you would like it to look.
Exclude it from the Outline filter.
Add a custom parameter Rename Glyphs for the outline instance and write comma=comma.ouline.
Add a custom parameter Remove Glyphs for both instances (normal and outline) and write comma.outline as the value.

Bonus: You can do this for all glyphs that you want to manually adjust. I would still suggest you try and make components as much as possible, but if you have a group of glyphs that you want to manually adjust, you can apply the above solution by doing

Rename Glyphs:


Remove Glyphs: *.outline

Remember to exlude them from the Outline filter as well, you can do this by writing exclude: *.outline

I will apply the components solution as much as possible for all the glyphs that is possible.

And will apply the alternate glyphs solution for these exceptions like comma.

Thanks a lot!

First time asking in forum and has been very helpful.


I’ve applied both solutions, depending on the characteristics of the glyps. All is working good in the preview panel. But something is wrong when exporting the font.

Next pic is the exported font

And these are the Custom Parameters I’ve used.

Thank you!

Can you send me the file?

Do you have an email to send it?



1 Like

Did you find the problem? Thanks :pray: :raised_hands: