Old-style kern table export


#1

Continuing the discussion from Too many kerning pairs:

Is it possible to get an old-style ‘kern’ table from Glyphs?

Thanks –
Micah


“Write Kern Table” Custom Parameter not working
#2

Wasn’t that clear from my post?

Why do you need it?

There was a discussion about this on TypeDrawer: http://typedrawers.com/discussion/comment/15644/#Comment_15644


#3

I guess it’s clear that Glyphs does not export a kern table: I happened to read your sentence that Glyphs doesn’t export a kern table by default, so I guess I shouldn’t’ve assumed.

I’ve got a situation with a particular renderer that doesn’t support GPOS (but yes to kern).


#4

Does your kerning data would fit in a kerning table? The biggest problem is to properly subset the kerning to fit it in the table. And as it doesn’t support classes, you need to decompose them and that adds a lot pairs.


#5

Good afternoon Georg –

Yes, my data should fit into a simple kerning table (and if it doesn’t, I’ll trim it until it does, as I don’t have a lot of options).

Thanks –
Micah

PS: One of my files that needs a kern table has 94 pairs, so it will definitely fit.


#6

I’m curious if it is now possible to export KERN tables?


#7

Yes (Write Kern Table parameter (it does not show up in the popup but does work)).

It will decompose all classes but will not do any filtering. (@davelab6: do you have some code to do that?)


#8

It would be nice to have an app preference to enable showing all possible parameters in the popup :smile:

No. I’ll let you know if I see any :slight_smile:


#9

There is a file that has all available parameter names. But not all are available everywhere. And only a few are not shown in the popup. Mostly, the implementation is not stable or the parameter was a requested for a special purpose.


#10

Hi Georg,

I need this as well, but when I try using this parameter there is no difference. Still no kern table exported. Did this possibility disappear?


#11

I just tried it and it worked as expected. You can add the parameter to the font or the instance and you need to check the checkbox.

And what version of Glyphs do you have?


#12

I just tried it again, in Font and in Instances. I used the checkbox but the kerntable doesn’t show up after export. If I import the file to fontlab, change it and export it again, it’s there. I am using Glyphs 2.4.4


#13

You have an old version that don’t support kern table. Please update to the latest version (if “Check for Update” doesn’t work, re-download the app from the website).


#14

Ouh! I didn’t expect that because I bought and downloaded it not that long ago. But thank you very much for your help! I’ll do so.