On exporting: glyphs not compatible


I’m trying to export my typeface to test it on Adobe apps. But, I got a warning on exporting that not all the glyphs are compatible, thus they’ll have no outlines! That means no character at all showing on the apps!

Below are some of the glyphs with compatibility problem: between the regular and the italic versions (the only two versions I created so far).




When I try to fix the compatibility issues, according to the tutorial, I got no results and the glyphs keep on displaying that light-red warning. Please, could you help me to solve that issue?

Thank you.

Do you like to interpolate between the shapes or are you just keep the two styles in one file?
You need to make sure the instance and master coordinates match.

I don’t plan to interpolate between these two styles, just trying to have them on the same file.

What I did that solve the “issue” was splitting these masters in 2 files. It’s not what I was trying to achieve, but it’s a way to have the typeface exported and ready to test. What I understood from this problem is that Glyphs always tries to match every master, even if you don’t want to interpolate — my case.

In my opinion, a humble one, maybe an easy option where we could tick to “tell” about this choice to the app could solve that kind of issue…

Thanks, @GeorgSeifert.

Could you send me the original .glyphs file?

Yes. Sending it through a private message here.

As I said. The masters have coordinations of 265 and 144 and there is one instance at position 100. If you add another instance and put them on the corresponding positions, you can export both masters just fine.
(when you do this, you might need to close and reopen the file to update all the red corners).

Hmm… Ok, I think I got it now. Thank you so much, Georg.

But just one more thing: I have exported the 2 separate files, regular and italic, but there were a mess in Illustrator. I just can find the “regular” one, but this is displaying only the italic glyphs! Is this something related to the file name or may I have done something else wrong, please?

Update: I’ve found it! I forgot to check on instances, but it keeps displaying only the italic version on Illustrator…

Update 2: I finally filled the italic angle and now it’s working fine!

1 Like

So everything is OK now?

1 Like

Yes, at least for now… :blush:

Thank you so much for your time, @mekkablue!

1 Like