One of the variable font axes doesn't work


#1

Hello, everybody! I hope you’re doing well.
I’m posting this here as I’ve been struggling in the past few days while creating a variable font. I’m working on the width and weight axes, so I drew the extreme masters of both (although I’ve used the offset curve script feature to create the bold version).

The thing is: when I export and try it on Adobe’s programs, I can just change the width, not the weight (I have the two sliders, but only one works fine). The other thing is, If I export in OTF, I can select all my 4 weights (light, regular, semibold and bold), but when using the variable version, I have 6 weights to choose from and in the wrong order (for example semibold, regular, bold and light, from top to bottom).

I’m using the newest version of Glyphs and I don’t get what I’m doing wrong. I’ve followed tutorials and even used one of the examples posted around here to guide me through the process. I would love to get your insight into this issue.

Thank you.
I hope you have a nice week ahead of you.


#2

We need more info. Can you post screenshots of your master settings or send us the file?

You only speak about weight instances and never mention the widths??


#3

Oh, I never thought you would be so quick, I was working on the screenshots, haha. I’m sorry, I’m new to this and not quite aware of how this works, but I’m an enthusiast.
The masters:


The font definitions.





I made the bold version this way (I think that the problem probably relies here on).



The width works fine, like I can change the width when using the font on Illustrator.

Thank you for your time!


#4

the for masters need to sit on a rectangle and one master in the centre.
You mixed the numbers quite a bit.
Something like a Regular in your case.
then you can do:
Regular: 500/5
Condensed: 500/3
Light: 300/5
Bold: 700/5
Expanded: 500/3

Or you do:
Light Condensed: 300/3
Light Expanded: 300/7
Bold Condensed: 700/3
Bold Expanded: 700/7


#5

On the masters or instances?


#6

Ok, I think I got it! I’m going to try with all the letters!
Thank you so much!