Opening CJK font - no response from Glyphs

Hello. :slight_smile: Whenever I try to open the font BabelStone Han, Glyphs returns no response. It doesn’t open the file, or give an error message etc.

Is there any reason for this? I have been doing workarounds using other software, but they are quite slow. It’d be to find a solution.


The font has a damaged post table. fontTools will not open it (at least it takes some serious time). OTMaster shows the problem: if you see the post table, there are a lot ‘.notdef’ glyphs at the end.

Because of the problem, it would take a VERY long time to open. I fixed that.

Hi Georg. Thanks for your help and sorry for the delay. I’ve been working with Glyphs Mini at work, with the full version at home. Finally, the full version is now installed at work as well.

When you say you’ve fixed it, do you mean you have a fixed file? Or is the damaged post table an obstacle that is just not easy to overcome?

I fixed it that Glyphs can import the file now. It is available in the latest cutting edge version (activate it in Preferences. You might like to duplicate the app before you update to retain a stable version of the app).

Thank you so much!! This is amazing :smiley: