Opening problem – Glyphs 3

Just licensed my Glyphs 3, installed some plugins from plugin manager and Remix tools, after that I reopened app and got this message:


this command: pip install pyobjc - did not do anything.
I have reinstalled the Python and then I got this message:

I have reopened app restarted computer but still get the same message.
Mac OS 10.15.5

Glyphs 2 works as good as before

What can be the reason?

If you typed 'pip" it should have been β€œpip3” to install the correct version.


I am not sure if it’s the correct way to check the version but is it the reason why Glyphs 3 does not open?

Glyphs 3 requires Python 3.8 or later to work properly.

How can I install it :pleading_face:
is there any command for terminal to do that or what could I do?

It can get complicated. Someone else would be better qualified to help you with that.

I had the same python but app was working normally today morning, I don’t think it’s the pithon issue…

You can install The Python 3 runtime packaged for Glyphs from within the menu Window > Plugin Manager. Select the Modules tab, and then Install next to where Python is indicated.

You can also select the installation of Python to use via Glyphs > Preferences > Addons

This is also described in the Extending of the what’s new in Glyphs 3: Making Things You Love post.

Also note that some plugins still need to be updated for Glyphs 3. To start Glyphs without loading plugins, hold down the Option and Shift keys. Some info about that is in the Crashes tutorial.

1 Like

Thank you so much for detailed answer. I was able to start the app while holding Option and Shift keys.
I have installed Python3 via plugin manager as you mentioned and than changed the use of Python:

And it works!

Thank you so much!

Also having the problem, after it crashed (I think while compiling features), it now asks to reopen or not, but no matter what I choose it crashes after showing the licensing window for half a second.

Tried, with no result:
removing Glyphs 3 folder from Application Support
removing com.GeorgSeifert.Glyphs3.plist
running with option + shift
reinstalling the app

Could you please help?

Can you drag the license onto the closed app?

Using a trial for now, but now it actually closes after showing for a second whether I want to check for updates, I guess that changed after removing the preferences.

I tired the same and for me is does work. Did you restart the mac?

1 Like

Accidently noticed com.GeorgSeifert.Glyphs3 folder in Application support, removed it too and it works after restart!