OpenType positioning bug?

I tried to follow this tutorial, Positioning with number values | Glyphs to use positioning method instead of substitution for .case glyphs.
When I write pos o <10 40 20 0>; in my “case” feature and compile nothing happen. Feature button in Preview Panel still gray, and no OpenType Feature are present in exported font.

AFAIK, GPOS is not working in Glyphs edit/preview view.
You need to check GPOS codes with “Text Preview” tool.

Ok, but I can’t enable opentype feature in Text Preview.

You can use the kern table with “# Automatic Code” to test:

@mekkablue It is possible to do it like in the tutorial ?

I’m coming back to this topic.
I tried to use positioning rule in OpenType case feature, with the following code :

pos @brackets <0 100 0 0>;

The exported font does not include the case feature.
To enable it, I need to add at least one substitution rule.

pos @brackets <0 100 0 0>;
sub O by O;

Maybe this is a bug @mekkablue @GeorgSeifert ?
Here is a Glyph test file : Test (3.6 KB)

When I export the font from Glyphs 3.1.2 and 3.2, it has a working ‘case’ feature.
Where did you test? I tested in FontGoggles.

You are right, this is an issue with Font Gauntlet !
I’m going to make a habit of always testing using FontGoogles from now on.

I’m seeing similar problems for stylistic sets.
When I only put position rules in a stylistic sets, it does export, but InDesign does not pick up the custom names. As soon there is at least one substitution in the feature, everything works as expected.