Opentype properties are not available

I exported my typeface to an OTF file, transferred it to my Windows PC and double-clicked on it and installed it. When I use the typeface in Adobe Indesign, I cannot choose alternate glyphs. When I highlight a character that has alternates and click on the opentype icon, it displays the error message “opentype properties are not available”.

That depends on the composer you use. They are only available in the classic composer, otherwise, you need to go through the menu of the character palette.

How do I choose alternate glyphs in the menu of the character pallet of InDesign? I used to be able to just click on the opentype icon to select the alternate glyph.

Do you add all the required OpenType features in your font?

I don’t know what you mean. I have alternates for some of the letters. Is that what you mean?

Indesign needs OpenType features to be able to access those alternates. How did you name the alternate letters?

The alternates are named A.alt1, E.alt1, E.alt2, E.alt3, E.alt4, N.alt2, etc.
I have enclosed the glyphs file.
La Sylphide.glyphs (75.2 KB)

This doesn’t work on Mac either. Placed the otf file in /Library/Application Support/Adobe/Fonts. Same error message.

As I thought, you don’t have any opentype features.

The easiest is to rename your glyphs like this (Edit > Find > Find and Replace…):

Then open Font Info > Features and press the Update button in the lower left.

The alternates work now. Thank you.

Works on Mac, but sill not working on Windows, though.

In which app do you test and how?

I use Adobe Indesign on Windows to test.

Do the stylistic sets not show up in the opentype menu of the character palette?

If not, I assume an installation problem. Are you using the Adobe Fonts folder?

Not sure where exactly the folder is located on Windows though.

I think that the folder is Program Files/Adobe/Adobe Indesign/Fonts. Will look for it tonight.

Thanks

It still doesn’t work after copying the otf file into C:\Program Files\Adobe\Adobe InDesign 2022\Fonts. When I highlight a letter and click on the opentype icon it still gives the “opentype properties are not available.”

There are two different problems here. Do you get the fonts installed properly and do the OpenType features work correctly. It seems that you have managed the first.

Can you show your feature code?

There are known issues with Windows 11 and .otf fonts

I’d be keen to know if .otf fonts are working OK in other apps on Winows 11