Overlapping inverse shape on ligatures


I’m new to Glyphs and have encountered a problem that doesn’t seem to be addressed directly in any other topic. When I export my script font and open it in Photoshop or Illustrator, there is an apparent overlap of characters in front of or after ligatures (ligatures only). It creates a hole the shape of the character’s overlap. I’m guessing this might be something obvious since I’m only getting this on the ligatures?

Can anyone help?


First thing to try is, in Glyphs, Edit > Correct Path Direction (or Cmd-Shift-R) with all contours selected.

1 Like

It worked! Thank you so much!

Actually it fixed my problem but now I’m getting a new one. Some of the paths on my characters have become warped (mostly straightened instead of curved) on export only. See below my path in Glyph vs. the exported version on Illustrator:


The node type you see is a Corner when it should be a Smooth You can fix this by either selecting the node and hitting Return or you can try the Paths -> Tidy Up Paths menu item. Corner is a blue square by default and smooth is a green circle node shape.

Two valuable items to look at, as it appears you are new to drawing in Glyphs:

and https://glyphsapp.com/tutorials/drawing-good-paths

Also, your paths are cut off in Illustrator due to a lack of proper vertical metrics data.

Thank you for your help!

I tried tidying up the paths and even changed a few nodes manually to the green circle nodes, but even then, I’m still having the same issue. Any other ideas on what could be causing the problem?

Another handy plug-in is Show Red Arrows You’re probably dealing with Inconsistent Smooth Connections where the control handles aren’t parallel. The Red arrows plug-in will show you parts of the drawing which possibly require attention. You can fix by selecting one of the handles on the node with the kinked curve and moving it one point in any direction, then back to the original coordinates, this will sync up the other handle. You can automate this if you purchase RMX Tools.

  • Are you exporting as TTF? Could be a conversion error. Try regular CFF (uncheck TTF at export).
  • How are you testing the font? Are you using the Adobe Fonts folder? Could be a font cache problem.
  • I wonder if the path has been copied and pasted on top of itself. Try double clicking next to it to select the whole path, and press Delete. Could be a problem of the overlap removal algorithm. (There is also a plug-in called Delete Duplicate Paths, and the Show Angled Handles plug-in helps you spot such cases.)

If that doesn’t solve it, could you send me the .glyphs file?

It was a conversion error @mekkablue, thank you!!! I exported as an OTF and it solved my problem.

Thank you all for your help!

Could you send me the file that produces the conversion error when exporting TrueType?

The paths are really messy and the exported TrueType outlines are indeed a bit bumpy, but I don’t see problems like in your screenshot. But I can’t find a glyph that looks like it, either.

The paths are messy because I’ve just started working with your program a couple weeks ago… I sent you my file to help you, the problem was already fixed on my side. But thanks for your helpful feedback…