Overlapping vectors

I’m seeing white areas in InDesign where the components of the glyph overlap – this is a google font that has already been published, to which I’m making some changes – the original doesn’t show this, only once I’ve opened the .ttf file and exported from Glyphs (I don’t have any .ufo files etc)
Screenshot 2022-12-06 at 17.50.29

Have you exported the font with the “Remove Overlap” option set? And can you check the path direction of both shapes?

It’s happening across the font – see screenshot attached.

The white overlaps disappear in Indesign when zoomed at 600%.

The font will be used onscreen and I won’t know if the overlaps will appear onscreen on the online platform or not until the developer works on it.

I exported with Remove Overlaps, same result.

Also, some of the overlaps can be fixed via the menu and others just won’t work - they remain as separate shapes

Why don’t you just use the original glyphs file?

It worked! I downloaded the .otf and it seems to have done the trick

I’m guessing you meant use the source files though – that will be next on my Glyphs tutorial to-do list


getting the .glpyhs file is really easy. You download the full repos (click in the green “Code” button. Unpack the .zip and find the .glyphs file in the src folder.

1 Like

I really need to also try and export the .otf font from our server that I’ve updated - the italic from Github is much more slanted

Do you think I need to delete some app files from the system or re-install the app perhaps to overcome the overlap problem at export?

Make sure your path direction is right. Otherwise double check if you are actually testing the font you just exported or if you are seeing an older export.

Are you using the Adobe Fonts folder?

It may be a font cache problem if you have not been using the Adobe Fonts Folder. Read this please: Eliminating font cache problems | Glyphs

Thanks mekkablue - still no luck though.

I’m using the Adobe fonts folder as you suggest, but still the overlap shows at export in both InDesign and illustrator (see screenshot). Oddly, the Regular weight isn’t a problem, although I didn’t do anything to it to stop the overlap at export.

Path directions are all correct and when creating outlines in InDesign it shows the overlap as a separate shape, just as the .ai shot below

I notice also that the original .otf shows the overlaps too in InDesign etc, but as black, not white – maybe this is a glitch in the .otf file and not something the Glyphs app can solve?

Screenshot 2022-12-12 at 18.15.08

Can you post a screenshot of those glyphs from the edit view?

It’s not possible to remove the overlap. Do you think the file is damaged?

Screenshot 2022-12-13 at 09.45.09
Screenshot 2022-12-13 at 09.44.55

Why in the world are you working with the ttf? This will only continue to cause problems for you.

Those are quadratic curves in your screenshot. Either you convert all curves to cubic (Path > Other > Convert to Cubic) or you just use the glyphs file I linked to above and work from an actual working file instead of an export.

Yes, better work with the source files, not the TTFs. As advised further above.

Sure, I understand that the source file is the way to go. I’m a complete beginner with all this. I have had success creating icon fonts from scratch and then got thrown in at the deep end, tasked with amending this font.

The deadline is looming and to amend the source file is beyond my skill set right now.

This font will be used in a limited fashion in an online project – I’m hoping that I can wing it while I gain experience for the next project.

If can extend the deadline I will endeavour to amend the source file.

Thanks for your comments and all the advice – really appreciate this forum.

It works exactly the same as opening the .ttf file. Just locate the .glyphs file and open that. Then do the same as you did to the existing file.

Thanks Georg – I can see that I’ll have to get my head around working with the various weights included in the source file

This tutorial might help (also check the related ones linked in the bottom of the page): Multiple Masters, part 1: setting up masters | Glyphs

1 Like