Overlaps showing on adobe print (only)

Hola - When I print my font using adobe apps, these overlaps show up. Even when I export the illustrator or indesign to Adobe PDF and print, this happens! I feel like I have tried everything. Made sure path direction correct. Exported .otf font with remove overlaps (and not remove overlaps.) tried lots of different adobe print settings. I am using post script drivers for my HP printer.

I’ll tell you what does work: printing in Microsoft Word. And exporting to a PDF and printing as an image. But I would really like to use my font in Adobe apps.

When I preview the font anywhere (Glyphs, font goggles etc) I don’t get the overlaps.

I realize this is more of an Adobe question than I Glyphs App question, but I am hoping this community has been down this issue before.

thanks much,
Jane


here is a lovely pic of my issue…

Normally caused by wrong path direction.

Wrong path direction a you might need to export with “Remove Overlap”.

How did you make sure of this? Can you show the path direction of your paths and try running Path > Correct Path Direction?

Yes, of course

Please know these are generally glyphs comprised of several components. The individual component paths are correct. When the components overlap, that is where I see the issue upon print.

The issue occurs when I export to Opentype. When I export to truetype I don’t have the issue (but I want opentype pls!)

'remove overlaps" checked upon export.

thanks

Also, as a test. I look one letter (lower case “L”). I exported it with the paths going the correct direction, but for fun also reverse the direction and exported it to OTF. The output was the same with the overlaps showing upon print.

And you are 100% sure you are using the latest exports? How are you installing your fonts?

I’m directly exporting them into the adobe Fonts folder. I can see the changes I just made adjust on the screen so I know I’m using the current export.

Can you send me the .glyphs file?

You didn’t mention that you use the lttr plugin. Please report to them that there is something wrong with the path direction.

Actually I added the LTTR plugin after the issue happened! I was hoping going that way could solve the problem, but only made it worse (glyphs crashes all the time now and I have asked LTTR to look at that issue)

So please don’t attribute the issue to LTTR.

Absent LTTR, this is a monoline font, and I use the offset curve custom parameter upon export.

I see. You need to check “Remove Overlaps” in the export panel.

I have tried that with no luck. I had tried it both unchecked and checked before. Sorry I sent you a version with it unchecked.

I have learned something new. I am using PostScript drivers on my HP printer. When I re-install the printer with PCL drivers, the overlaps go away. Now I have to go down my own printer rabbit hole as I always thought PS drivers were better than PCL drivers.

Bottom line, this wasn’t a Glyphs issue. I appreciate the time as always.
Jane

You didn’t mention your OS, but if you are using Sonoma that might be a clue as to Postscript issues with your font since Sonoma dropped support for Postscript. Also, I don’t know if your HP printer has genuine Postscript or an emulation.

I have a printer with Adobe Postscript 3 yet it shows up on my Sonoma machine as “generic Postscript printer” so I suspect Sonoma is ignoring the installed PPD for the printer. It still works but I have not compared the output to my old Intel machine yet although I need to.

George - Indeed indeed. I am Mac. And using PS drivers. I knew about the Sonoma thing but am hanging on for as long as I can. For my HP printer (which I do love) the only drivers that seem to work are PS (where I get all the print options) and the dumbed down Mac AirPrint Drivers (where I get none.) PCL drivers don’t print color. If anyone knows of some other mystical drivers that work, please LMK!

Sure enough I did a new printer install using the dumbed down AirPrint drivers and viola the overlaps are gone. Geez.

thanks much for the reply.

Jane

Those gaps as you see them in your images are overlaps in the outlines, for sure. So the remove overlap didn’t work or you looking at outdated fonts.