Path order problem

I am having a hard time fixing the order of the paths here and tried everything on the tutorial article and many of the recommended solution on the forum but still wouldn’t solve it

I know there is not a manual way to order the paths but what do you advise to do in this situation?

Seems not like a path order problem (i.e. whether left or right accent is considered first), but rather mismatched first nodes. Right-click on the bottom right corner of each of your quadrilaterals in this master and select Make Node First.

1 Like

Thank you so much
that totally fixed it

Glad it worked. When trying to fix paths, Glyphs chooses the bottom-most point. If there are two at the same height, it chooses the one to the left. Occasionally, as here, that guesswork messes up interpolation.

1 Like

@eliason I have a similar issue with another font but i tried your advice on it but it didn’t work this time

I would be very grateful if you can help me with understanding this issue as well

Hi Gaber, send me the file with and perhaps I can help you.
May be a single glyph.
Cheers, Edu

1 Like

You may need to sort it out with Filter > Fix Compatibility.

I did fix the compatibility using the filter but it still wouldnt export says the glyph has compatibility issue

I shared a copy with @etunni and he sent me a screenshot of the glyph working fine on this version of Glyphs but on mine it wouldnt export
I’m running Version 2.6.5 (1330)

Might be a good idea to update to [1338]; it may fix the issue.

Are you exporting as TTF?

I’m trying to export variable font to test

Very shallow inflections may be hard to convert to TT curves.

Also check for anchor compatibility. And add an Enforce Compatibility Check parameter in Font Info > Font. Does Glyphs show the glyph as incompatible?

I already added the enforce compatibility check parameter and all anchors are compatible yet it wouldnt export the glyph and gives the incompatibility red flag

Can you send me the file?

1 Like

I just sent it

In the file you sent, the outlines are simply not compatible (different node count). Do you know this:

@mekkablue I do and i went through it multiple times and didnt notice any difference in node count
will recheck on that again now

The outlines are marked in red if they are not compatible. That is the clue for further investigation: must be either node count, node type (on-curve vs. off-curve), or start point position.

@mekkablue I am pretty sure it’s not node count as I did the counting over and over again and tried to fix the start point position also with no luck with getting it fixed
but i will re do the troubleshooting over again and try to figure it out

the odd observation is that the font file showed no compatibility issues on @etunni when he checked the source file!