Performance issue for large files/"auto-saving"?

I’m experiencing some serious performance issues where for about every half-minute or so, Glyphs turns into non-responding mode for like 10 seconds for a large CJK glyph set (~27000 glyphs) with multiple masters.


It’s very annoying but I have to stick to Glyphs for now. I’ll have to work with large files with multiple masters and this frequent “down time” is driving me crazy…I’m using the new MBP so it should be pretty powerful. My gestimate is that Glyphs trying to auto-save because a manual save also cost the similar amount of “down time”? If so, is there any way to turn off auto-save? It would be really appreciated!

Can you send me the file that I can check if I can optimize the performance?
And you can disable the autosaving by running this line in the macro panel

NSDocumentController.setAutosavingDelay_(0)

If you do this, make sure to press Cmd+S regularly.
Or use a longer timer:

NSDocumentController.setAutosavingDelay_(300) # 5 min

Thank you very much, but when I tried to run this in Macro panel, it shows an error:

I’ll have to ask my boss if I could send you the file :joy:

We often use a special workflow named collaboration; for successful execution, all employees MUST work on the server, in pandemic times even over VPN. The autosave makes this not really workable. But good to know that the interval can be controlled.
Wouldn’t it be more efficient if those autosave files are stored locally? Or could they be saved by an idle CPU in the background? Or only contain the differences?

Sorry, forgot one part:

NSDocumentController.sharedDocumentController().setAutosavingDelay_(300)

There will be something like this in the next version.

Writing in the background is tricky. Because you will change the file while it saves so writing it out then will have inconsistent data.

1 Like