Pixel tool deletes wrong pixel


Rainer’s pixel tool sometimes deletes the neighboring pixel, not sure why it happens :frowning: Is it fixable or am I doing something wrong?

What does your original pixel glyph look like? Make sure the bottom left corner of the pixel square is at 0, 0.

Not mine. :slight_smile:

1 Like

The pixel square originates at 0, 0. It happens sometimes and works as expected other times.

Georg’s? I just meant it’s not the Toshe’s one :smiley:

Can you reproduce reliably with certain pixels? Like in certain positions or always in the same glyph?

Okay, I think it happens when the pixels are rotated 90 or 180 degrees, flipped pixels as well.
Does that help?

also reported in mini:


bug always present, even without rotation

  1. create new file
  2. set grid spacing to 100
  3. create a 100x100 pixel glyph
    Result:
    Pixel tool deletes/creates wrong pixel

Then I’d rather suggest to fix the pixel transformations. There is a mekka blue script called Pixelfont > Reset Rotated and Mirrored Components for that very purpose.

Thanks for the reminder. I fixed it an uploaded a new version.

And I improved the python pixel tool, too.

I tried it, but the macro panel throws this error:
print “Fixing %i components in %s …” % ( numOfComponents, glyphName )
^
SyntaxError: invalid syntax

and nothing seems to happen.

I reinstalled it and it seems to work fine on flipped pixels, but is still off on rotated.
On another note, do you happen to have a script that would step through components and slant them to a specified degree in place? :slight_smile:

Can you send me a sample of pixel glyphs, so I can update the script?

This is easy to do yourself if you read through the the Scripting tutorials. Hint: installing the Python for Glyphs snippets helps with the transformation, there is one snippet called transform.

Yeah, I’ve sent you an email.

The script had an error that prevented it from running properly. Fixed now. Please update your script repo. (If you have it as a git repo in your Scripts folder, you can run mekkablue scripts > App > Update git Repositories in Scripts Folder.)


The script seems to work, but now I get this.
The pointer was a rotated nasted component, which I decomposed (the script would correctly rotate the whole nested component back, but that’s not what I need here); the single pixel components are shown as rotated, enabling/disabling auto alignment does nothing :confused:

Have you tried the lates version of the pixel plugin? It should work with transformed components.

Yes, I’ve just reinstalled it again: it works on flipped components, but not on rotated.

Can you send me a file with a rotated component that doesn’t work?

Yup, I’ve sent you the file.

The script did not disable the automatic alignment. That’s why they snapped to the baseline. Sorry, it was a very old script and not used and updated in a long time. I just uploaded a fix. Please update your script repository. And thanks for your feedback and patience :slight_smile: