Pixelate Filter doesn't work and crashes Glyphs

Hey there,
I tried to use the pixelate filter by @mekkablue various times, but it didn’t do anything to the selected glyphs. It opened, but there was no change, no additional glyph or anything. Not sure how it works since the short How to use on the Glyphs Website was everything I could find.
For my tests I used letters from an existing font of mine that I wanted to do a pixel style font with.
Unfortunately after a few tries the filter also crashed my Glyphs. I even had to reinstall it, and it just worked again until I deleted the plugin entirely from the application folders.
I’m sure that this filter works fine with others, so I don’t know what’s wrong. Completely lost!
Would be so happy if someone could help.

It seems that you need to add a glyph called “pixel”. The filter should warn about this.

Thanks for the fast reply!
Unfortunately it still doesn’t work. As soon as I click the filter Glyphs stops responding. Now re-installed the filter. As soon as I open it, Glyphs needs to process every step for some minutes.
I also created a glyph named ‘pixel’ as you recommended and copy-pasted the glyph I wanted to pixelate there. Is this how it works? When I used the pixelate filter on that glyph, it created almost 4000 copies of the selected shape inside the glyph. Then Glyphs crashed.
I have no idea how to use the filter since warnings seem not to work here (no warning about the extra glyph pixel etc.). What could be the problem?

The “pixel” glyph should only have the shape that you like to have as the pixel. Mostly a square or cycle. In the lower left of the bounding box, on the baseline.

The filter works for me as expected.

  • Which version of the app are you using?
  • Can you post a screenshot of the filter settings?

Edit: I added error messages in Macro Window. So update the plug-in please and see if there is something printed Window > Macro Panel.