Plugin Folder Permissions

Tried installing SuperTools in this plugin manager and was hit with this error message

Permissions of the Plugin folder seems fine. Installing other Plugins through the plugin manager yields no problem. It just seems to be SuperTool specific.

Installing SuperTool manually results in this where the options are not available:

45%20PM

Resetted Glyphs multiple times, uninstalled, re-installed. Changed permissions multiple times

using Catalina I guess, it’s a mess with permissions…

Tried going to:
System Preferences > Security & Privacy > Privacy > Files and Folders
see if there’s anything without a check that needs to be checked.
Also check the other options as well (Accessibility, etc)

Yeah it’s Catalina, I’ve tried giving it full disk access and other options but no dice

You don’t need to do anything with the app itself. That is almost never a cause of problems like this.

Please check the Plugin and Repository folder. You can find it from the Script menu > Open Script Folder.

Sorry not sure if I made this clear enough but I said I’ve checked the folder multiple times. Something is clearly wrong. The permissions isn’t the actual issue. It has something to do with the repository of SuperTool itself. Installation of every other plugin has been fine.

I would remove anything “SuperTool” from both folders and try again. It might be that there is an old file in either of the folders and that is causing this.

Georg, I’m grateful for all your help but I’ve removed it over and over and over again and I’ve been trying it all day.

I’ve removed SuperTool from both folders multiple times. The problem is still there.

I’ve tried installing via Plug-in Manager, as well as manually.

I’ve reproduced this problem multiple times under various conditions.

I’ve uninstalled Glyphs and Re-installed it.

So, can you remove the Repositories and the Plugins folder (rename then for now). Then restart Glyphs, and load the plugin from the Plugin Manager. Then post a screenshot of the content of the two folders.

You need to activate the tool in the toolbar. Only then are these options enabled.

Renamed both folders. Here is the error message as well as the folder contents of the new folders.

That is interesting. It has downloaded the wrong repository. It has nothing do to with the write permissions but the plugin is simply not there.

Can you run this command in terminal and post the result:

git --version

When I get these permission errors, I click the Install button again. Second or third time, it usually works.

So I tried even 5 time - same warning “could not install plugin…”
This only happens when I tried to install the GaugeTool plugin.

Any idea?
OS BigSur 11.5.1

Thaks

Can you check the Repository and Plugins folder if there is any leftover from previous installations.