Plugins are crashing in 3.1

Hi! Since today most of my Glyphs-plugins are crashing when I open Glyphs. There was no update or anything, so this came out of nowhere. I’m running Glyphs 3.1 (3133) on Big Sur version 11.6.7. The affected plugins are Word-o-mat and Show Smooth Node Angle and Proportion. My other plugins, StemThickness and Variable Font Preview, are working just fine.

A popup told me to install pyobjc, which I did – plugins are still crashing. I deinstalled and installed them again and I restarted my computer, nothing worked. I also made sure that I have the latest version of pip3 and tried to install pyobjc again – it says that all requirements are satisfied. But the plugins still don’t work.

Could you please help me out?

What version of python and pyobjc do you have?

I have Python 3.9.13 and pyobjc 7.1

Apparently this also affects some of my own scripts …

I get this error message and don’t really know what to do with it:

Traceback (most recent call last):
File “runMacroFile”, line 1
ModuleNotFoundError: No module named ‘objc’
Traceback (most recent call last):
File “”, line 15
the_font = Glyphs.font
NameError: name ‘Glyphs’ is not defined

Maybe I should try to get a newer pyobjc version?

The best option is to install the python version from the plugin manager and select it in preferences > Addons. You need to restart the app between installing And selecting it. And after selecting it, restart again (I’m working on improving on this).

If that doesn’t work, manually remove the glyphsPython from ~/Application Support/Glyphs 3/Repositories/ and reinstall it from the plugin manager.

Thanks for your reply!

Unfortunately it didn’t work at first. But after deinstalling homebrew, my other python versions and reinstalling pip3, it’s sorted out.

I don’t know what caused the problem or which of these things solved it, but now everything works again. :relieved: