Plugins don't show up in view or filter

Hello, everyone! I just got Glyphs 3 and am delightfully exploring the features. The only issue is that plugins don’t show up in the filter or view, and this is annoying! I have emptied them in the folder and reinstalled them in the plugin manager, but none are working. Can anyone help me with this? Thanks!

Have you restarted the app?

And did you also property installed the Python module?

Hi Georg, thanks for responding so quickly! And yes, I’ve restarted the app multiple times, and I also installed the Python module. but I’m not sure if I “properly” installed it, can you educate me?

Can you copy this into the macro panel and click the Run button?

print('Hallo')

when i ran it the whole app crashed… the same issue happens if i run any script in the app

If properly installed, in your Glyphs 3 Repositories folder there should be a folder named “GlyphsPythonPlugin”. If it isn’t there, the Glyphs Python plugin needs to be installed, found under the Plugin Manager > Modules tab. Please check that.


Its there!

Verify the selected Python in Glyphs > Settings > Addons > Python version. To use python, make sure you pick the one that says ‘Glyphs’ after the version number.

1 Like

@awesam which plugin are you trying to install and see?

Can you please try to run that command I mentioned earlier to verify that python is installed properly?

They said that the app crashes when they did that.

Then the python module was installed incorrectly. Please remove it (maybe even manually from the repo folder) and then reinstall it from the plugin manager.