Preview glyphs using stroke

I’m using stroke to create a glyph. It looks correct on the glyph list, looks correct on the top panel (image attached) but displays the shape and not the stroke on the bottom panel. I know that if I expand the outline it works, but then I lose the flexibility to edit it.

Is there a way to fix/change the preview on the bottom panel?

Consider adding an instance in Font Info > Exports, and preview that one.

Those 5 below are exports. The issue is that the preview is presenting the shape, not the stroke. If I cut that line, it then displays the stroke, but as a “closed shape”, it doesn’t.

It works for me. What version of Glyphs do you have?

Version 3.0.4 (3108)

Then please update to the latest cutting edge version (activate it in Preferences > Updates > Show cutting edge versions).

Done. Still happening :confused:

Could you send me the .glyphs file?

Stroke Issue.glyphs (2.6 KB)

The problem seems to be the “Round Corner” filter. I’ll have a look.

I fixed it.

Awesome! Will it be available in an update soon?
Btw, this is the best product support I’ve ever seen.