Preview in AI font list incomplete

This feels like a silly question, but does anyone know how to prepare your font in Glyphs Mini so that the little preview in the character list in an app like AI says the name of the font in the font’s style? For example, I want someone to see “Seoul Sans” in the font selection list in AI but right now it looks like the attached screenshot. I read the article in font cacheing and tried the terminal commands / computer restart method but I’m still seeing the same thing. The second screenshot is definitely showing the first letters of the words “Seoul Sans Regular”. I still think it might be a cache thing.

Do you have all Lower and upper case letters?

It’s an all caps front and I wrote a recipe that links the caps with lowercase.

Did you see this tutorial:
Can you check if the font that is active in Illustrator has all upper and lowercase?

I read the tutorial and started exporting my font versions to the “Font” folder in “Adobe” folder (originally didn’t see a “Font” folder and didn’t think to create one so I was saving to desktop, dragging to Font Book). I now deleted the font from Font Book and exported from Glyphs to “Font” folder in “Adobe” folder hoping that it would resolve cacheing issues, but the preview in the AI character window is the same. I’m not sure how to test what you’re asking - the font in glyphs has the uppercase tied to lowercase using a recipe and the font works as uppercase when caps lock is on or off. I open glyph window in AI and both upper and lowercase windows have uppercase glyphs. In PS the preview shows the standard “Sample” using the font style, so caps don’t seem to be a problem there.

After having installed the fonts in the system, it would be a good idea to change the font name to be sure to avoid cache problems.

It worked :grinning: Thanks!