Preview panel missing bug


#1

In the latest cutting edge version, the preview panel has vanished and will not come back by clicking the eye icon:
(The free-floating separate preview panel can be brought up OK).49


Preview problem in 1184
I can't open the instances view with the latest 2.5.2 (1184)
#2

It works fine for me. Can you try to remove the preferences file (~/Library/Preferences/com.GeorgSeifert.Glyphs2.plist)?


#3

Nope, no joy.


#4

Can you re-download and re-update the app?


#5

Hi,
I have the same issue, and deleting your preferences don’t resolve it.
I don’t tried Mekka suggestion yet.


#6

Is there anything happening in Console.app when you click on the icon for opening the preview area?


#7

Nothing.


#8

Which OS version are you using?


#9

10.12.4 with the latest cutting edge [1184]

Cutting edge 1181 works right


#10

Hi there,

Since I updated Glyphs this morning I can open the the instances view. Please fix. Regards. R.

28


#11

I just upgraded from 1175, on Sierra 10.12.6.

When I click the preview eye on the bottom left, nothing happens. Is this a known bug?


#12

Hello @Sindre and @RamiroEspinoza: I moved your posts to this topic. Some users experience this issue, but not all. As far as I can tell, only users of macOS 10.12 are affected. We are still researching the cause.

Workarounds until the bug is fixed:
a. Use Window > Preview Panel instead
b. Downgrade to 1181: http://updates.glyphsapp.com/Glyphs2.5.2-1181.zip
c. Upgrade to macOS 10.13 High Sierra or 10.14 Mojave


#13

Thanks but my OS is 10.10.5 and I can’t upgrade it because I need it for other software to work properly.


#14

Then try one of the other two workarounds.


#15

I can reproduce it. I’ll have a look.

edit: I fixed it.