Print to pdf and then edit the pdf

I’m wondering if it’s possible to change the font that is being used for glyphs names/unicode when printing in PDF.
For the moment, when opening the pdf, all text is changing. See screenshot.

I need to create a reference file/manual for a font and it’s not fun to manually print names and unicodes values so I was hoping to do the Save as PDF then open the file in Illustrator to add information/images I need to the file.

That is interesting. But I fear that I can’t do much about it. You might try to write an drawbot script that produces the PDF as you need it.

OS X 10.10.5, G2.4.2 [1034], Illustrator CS6.
I just tried it and it works OK for me, no garbling of names. How do you manage your fonts?

I believe it has to do with the new San Francisco system font, which was not in the 10.10 system yet.

Is seems to have to do with the new system font. I changed it to use Lucida and now it works.

Thank you guys!
@GeorgSeifert was this added to the latest update? It still doesn’t work for me :-/
@George_Thomas - Suitcase Fusion but I’ve never uninstalled system fonts

The problem is that SF is not really accessible like other fonts. Lucida will fix that. In the upcoming cutting edge version.

Illustrator should be able to substitute the font if it’s missing. So there is something going on with the San Francisco font.

I’m not sure if it’s related but i’ve had something like this with an InDesign document.

I made a specimen and added all the characters using a plugin ( that is probably putting all the characters by their Glyph ID.

Because of that when you change the font the whole thing falls apart and glyphs get substituted.

I used to run into the same problem during preflighting with PDFs that used certain Microsoft-published TrueType fonts that were brought over to the Mac platform and opened in Illustrator. Microsoft had engineered something into the fonts and I was never able to figure out what it was. Probably the same thing going on with San Francisco.

I must have tried it thousand times or even more, but it led me to nothing while using Adobe Acrobat, to be blunt. I and still hadn’t figured out why Adobe tools only have that issue and everything is fine about others. For example, when opening the exact document via this editor it opens up as supposes to, without any errors with values layout or something. The same with Foxit, Gimp, Sumatra and else

I am also trying this but not succeeding. I want to print a pdf book. I want to print a deep work pdf book. What should I do for this purpose?

@neilvick I’m not sure you are in the right place. We do type, not book design.

Thanks George Seifert for your response