Private use glyph is not visible in Illustrator

I have 8 symbols in the Private Use Area (uniE001-uniE008) and 7 of them are fine and visible in Illustrator. The problem is with the 8th one. It is visible in InDesign but not in Illustrator CS6.

I’ve tried everything - changing the glyph’s name, cleaning up paths etc. - nothing works. If I use one of the existing names (Trademark glyph), Illustrator shows this one but then 7th glyph in the Private Use Area is not showing up…

I’m not sure if it’s a Glyphs export issue or an Illustrator’s one. Any suggestions very much appreciated as the problem is driving me nuts :slight_smile:

Is there any restrictions in how many glyphs Illustrator can display?

This sounds like a font cache problem. How do you install the font.

Please read this:

I use Suitcase Fusion to install/uninstall fonts. I delete the font and install it as a new one every time I make a change and want to see how it works. All other changes are visible straight away. So to me it doesn’t look like a cache problem…

Just tried to install the font in the Fonts folder - no changes.

All glyphs I’ve added after uniE007 are not visible in Illustrator but I can see them in InDesign…

This is very likely a cache problem. If you want to test the font, do not use FontBook, Suitcase, or FontExplorer to install it in the system. Here is why:

Try with a different name in the Adobe Fonts folder. If that still does not work, please send us the .glyphs file: support (at) (this website name without www).

Thank you. Will do what you’ve suggested and let you know.
Meanwhile it worked when i did the export from Glyph 2…