Problem exporting Ufo files which have multiple-component Glyphs inside them

Dear Community,

I’m working with a multiple-Master *.glyphs project with 3 instances. Some of my characters are using components which again are composed using several components.

Generating those instances worked out fine and everything seemed in place. Yet, when trying to again save those as separate *.ufo files, the resulting *.ufo files contained problems. Some of my components where gone, and others were misplaced.

Do you have any idea what the problem could be?

From the moment on when having generated those instances, should I use the “Save as” or the “Export” function in order to save them as *.ufo files?

Many thanks,

What version of Glyphs do you use?

What are the names of the glyphs that miss the components?

Saving in UFO may be lossy because not all info in a .glyphs file can be stored inside the UFO format. So I recommend saving as Glyphs file, and exporting as UFO.

Thanks to both of you!

The problematic glyphs are composed of:

lc_halfserife_left_bottom, lc_halfserife_left_top, lc_halfserife_right_bottom, lc_halfserife_right_top, lc_serife_left_bottom, lc_serife_left_top, lc_serife_right_bottom, lc_serife_right_top, uc_halfserife_left_bottom, uc_halfserife_left_top, uc_halfserife_right_bottom, uc_halfserife_right_top, uc_serife_left_bottom, uc_serife_left_top, uc_serife_right_bottom, uc_serife_right_top,


A.001, AE.001, B.001, C.001, D.001, E.001, F.001, G.001, H.001, I.001, IJ.001, J.001, K.001, L.001, M.001, N.001, Eng.001, O.001, OE.001, P.001, Thorn.001, Q.001, R.001, S.001, T.001, U.001, V.001, W.001, X.001, Y.001, Z.001, Eng.002, a.001, ae.001, b.001, c.001, d.001, e.001, f.001, g.001, h.001, idotless.001, ij.001, jdotless.001, k.001, l.001, m.001, n.001, o.001, p.001, q.001, r.001, s.001, germandbls.001, t.001, u.001, v.001, w.001, x.001, y.001, z.001, c.002, W_W_W.001, Omega.001, mu.001, pi.001, zero.001, one.001, two.001, three.001, four.001, five.001, six.001, seven.001, eight.001, nine.001, zero.osf.001, zero.posf.001, one.posf.001, two.posf.001, three.posf.001, four.posf.001, five.posf.001, six.posf.001, seven.posf.001, eight.posf.001, nine.posf.001, question.001, dollar.001, euro.001, sterling.001, yen.001, ampersand.001, paragraph.001, section.001,

… and their accented characters - which might be logical. In any case:

acute, grave, circumflex, dieresis, tilde, macron, breve, dotaccent, ring, hungarumlaut, caron, ringacute, dotaccent.low, cedilla, ogonek, acute.caps, grave.caps, circumflex.caps, dieresis.caps, tilde.caps, macron.caps, breve.caps, dotaccent.caps, ring.caps, hungarumlaut.caps, caron.caps, ringacute.caps,

Thank you a lot!

Hello again, I tried to illustrate better how my glyphs are composed:

– A.001 = sceleton
– a set of serifs and half-serifs for bottom and top, left and right

My serifs again use components, for instance:
“uc_serife_right_bottom” and “uc_serife_left_top” are components of “uc_serife_left_bottom”

My final letter A is composed of:
– A.001 + “uc_serife_left_bottom” + “uc_serife_right_bottom” + “uc_serife_left_top”

Perhaps this helps finding my problem?

Could you send me the .glyphs file?

Sure, just did! Thank you, Johannes

This seems to work in the latest beta. Can you please test this. To get it, select “Show Cutting edge versions” in Preferences > Update.

1 Like

Dear Georg, thank you so much! It worked now with the Beta. Few glyphs where displaced (and had a little exclamation mark in a triangle next to them), yet I could save the generated instances as *.glyphs files, and export flawless *.ufo files from there.

Thanks again!

1 Like