Problem with edited Google Font in Illustrator

I’m struggling with this glitch in Illustrator.
I’ve tried all export options, but the edit in font was just a small change in name. There is no chance the last edit could make any serious problem, so there should be a problem

  1. in Glyphs export
  2. in last Illustrator update
  3. between keyboard and chair

Have you ever seen this kind of issue? Thanks!

Edited google font – Roboto Condensed displays correctly after few edits, but after few months (not sure if there was any Glyphs update?), last export displays like you can see in screenshot. Looks normal in Glyphs, Pages, Right Font, Font Book etc, but in Illustrator always glitched.

That might be the original TrueType data that was corrupted when im/exporting.
Can you try to export as .otf?

Thanks for that quick reply!
Actually! OTF + overlap option (don’t know why) enabled works!
Thanks Georg!

But why? I’ve tried original file
a) from google fonts
b) source from google fonts github
What kind of corruption it that could be?
I’ve never seen this behaviour yet.

I found the problem and fixed it. Thanks for finding and reporting this.