Problem with languagesystem DFLT and latn


#1

The first time I export the font, it show “languagesystem DFLT dflt;” in the feature.
When in Glyphs, all my .liga/ .end/ .init/ dlig work fine.
When I try to test my font in illustrator, those ligatures just won’t show up. (my open type setting is ON).
I can see my ligatures in illustrator’s glyphs panel, but when I click on them, nothing happen.
example:


Tested in Photoshop, not working either.
Tried copy the ligature from Font book to Pages, not working.

I go back to my Glyphs file, change the “languagesystem DFLT dflt;” to “languagesystem latn dflt;”
export my font, test in illustrator and the ligatures/ end form works!!
but then I found some problems and need to edit my font. So I go back to the glyphs file (with languagesystem latn) to edit. Now I can’t access the ligatures even I have turn on the standard ligature in the preview.

So I changed the "languagesystem " back to “languagesystem DFLT dflt;” and the ligatures show back again in Glyphs again.
Is this normal? I should export my font with “languagesystem latn dflt;” but when I edit it, I should change it back to languagesystem DFLT dflt;?

Glyphs version: Glyhps 2.4.4
Mac OS Mojave: 10.14.1


#2

What happens if you simply automate the languagesystems?

In which feature did you put the ligature code? The AI screenshot says salt, which would be a bad idea.

And are you using the Adobe Fonts folder?
http://www.glyphsapp.com/tutorials/testing-your-fonts-in-adobe-apps


#3

Do you have any script/language tags in the feature code?