Problem with Remove Overlap filter on export

Hey, I just updated to the latest Glyphs version 2.6.5 (1292) today and started getting these errors on export:
Something went wrong with the Remove Overlap filter in glyph: Adieresis

It’s a new glyph each time, but seems to only be uppercase compound glyphs.
I followed advice in old, but similar posts; I compiled and updated features, but no success.

I’m on MacOS Sierra 10.12.5

Any guess?

Same error here, with the same version but on Catalina :s

Try emptying out the Temp folder and restart the app.

If the problem persists, consider temporarily downgrading to 1291:

Edit: corrected the version (1291, not 1191).

Just emptied it out with no luck. Will downgrade soon :slight_smile:
EDIT: Just downgraded and I am having the same error.

What version did you have before?

2.6.5, the latest.
EDIT: Prior to that, I think it was 2.6.4

Sorry I posted the wrong link at first. Now updated, try again please.

Same issue here.

I tried 1291 and the issue remains.

1292 is available for download now.

Not sure which one I had. But haven’t updated in a while, so not a very recent build.

Does it work when you run the Remove Overlap filter in the edit view?

Just tried with the new version 1291 and almost worked :s

macOS 10.13.6, G2.6.5 [1292] – I just tried it in Font View and Edit View; neither worked.

I’m on it.

1 Like

Just tried [1293] in Edit View, and now it is cutting out the overlap although not deleting it.

Can you send me a sample?

Not necessary now. Just went back and tried it again so it’s working now. Strange.

If it happens again I will send the file.

Latest build is complaining about Overlaps and when I turn ‘Remove Overlap’ off the built fonts are all screwed up

It’s working for me now, on 2.6.5 (1293)