Problem with unnecessarily snapping to grid

Having some trouble with Glyphs snapping to the Grid. I’ve been going through the tutorial and have got to the part bout the Extrem points. Problem is, when I add them, they snap to the grid as well as the handlebars and distort my icon shape. Even weirder is when I try and undo the points and handlebars snap to the grid and is distorted further. The only way I can get my original shape back is to copy and paste from Illustrator. Similarly, when I try and delete points to simplify the shape, in the demo, the curve neatly maintains the shape while removing the extra points but when I try it, the point and handlebars snap to the grid distorting the curve. Again, trying to undo distorts the shape further as the points and handlebars snap to grid. Is anyone else having this issue? Is there a setting I’m not seeing that needs to be turned on/off?

Please let me know if you can help. Thank ye.

Can you post a screenshot?

Font are usually drawn on a one unit grid. For normal glyph shapes this is enough resolution and even helps drawing consistently. If you draw icons you might need more. You have two options. Use a bigger UPM size or disable the grid. The latter works only of you plan to export as .otf as TrueType does not support fractional coordinates.

Georg, I’ve been advocating this for a while. I think, there should be an option to disable snapping to grid just for handles.

Grids could be used for other cases than just rounding the final coordinates, but distorting the shapes makes it impossible.

BTW shouldn’t rounding coordinates be an option next to ‘Remove Overlap’ in the export dialog?

Coordinates get rounded at export according to your grid settings. If you do not want rounding, you can use a Grid Step custom parameter with Value zero.

How do I disable the grid?

I couldn’t attach the image for some reason so I’ve attached links to what I see:


Add Extremes:


As you can see in the latter two images, the points and handlebars snap to the grid. I don’t know how to prevent this.

Thanks everyone


Why did you set a big grid like this? Goto Font Info > Other Settings > Grid Spacing and set it to 1. If you like to have the big grit, put the same number in the subdivision field.

Hi Georg. I was following the tutorial when I built this and your comment actually solved my problem. Apparently I messed up my subdivisions. Thanks for that. In the tutorial he does say that the grid setting is probably bigger than we need but he set his Grid Spacing and Subdivisions to 128. I missed changing my subdivisions to 128. Everything seems to work peachy keen now. Thanks a bunch.