Problems with Disable Masters Custom Parameter

Version 3.2 (3179), Working with a font with two axis, four masters.

When I try to export instances with the the “Disable Masters” parameter, some fonts don’t export, while others with the same parameter do export. This warning come up:
The “Disable Masters” parameter removed all needed masters for the instance: Gineto Fit Black

The masters I list in the parameter should not affect the instances. Also, my Italic file is set up in the same way and it exports with no problems.
These files are coming from Glyphs 2, and this didn’t happen then.

can you send me the file that shows this error, but also an example of a file that works with the same setup.