Problems with Glyphs 3 on OSX El Capitan 10.11.6


Since updating to Glyphs 3 i got several Problems (some may already be listed).

Trying to open Glyphs 2 files causes Glyphs 3 to crash.
Trying to set up new instances causes Glyphs 3 to crash.
Copy paste components makes them appear shifted to the right and not on top of the original component as normal objects behave (and how it worked in Glyphs 2).
Components are not movable by mouse or keyboard when there are only components in the glyph. They get movable when i add a normal object.

Since yesterday Glyphs 3 gets stuck in the crash-report window when i try to open it. I am not able to use it anymore.

I am using OSX El Capitan 10.11.6.



can you activate “Show Cutting Edge versions” in Preference > Updates and check for updates?

First of all thank you for the quick answer.
The main problem (stuck in the crash-report window) has somehow solved itself.
After that i was able to update to version 3.0.1 (3035) but the rest of the listed Problems stay the same.
I now noticed that the latest Version of Glyphs 2 had similar weird behaviour when it comes to components. Did you change something about dealing with components at an earlier point maybe out of some reason i just don’t understand at this point?

That shifting is the automatic alignment. And that might be active for more glyphs by default. If you don’t need it, you can disable it for the whole font in Font Info > Other > Disable Automatic alignment.

Okay so that was my fault. Now we are left with the crashing issues which i think were also mentioned by several other people.
Thank you for the immediate help!

I am again stuck in the crash-report window as i was before. The program crashed when i tried to add stems to a master. Last time the the problem solved itself, as i said before… i am waiting for something magic to happen again now.
Just wanted to let you know as i cannot send a crash-report about how i got stuck in the crash-report window :wink: