Problems with Scripts and Plugins on MacBook Pro M1 Max (macOS Monterey 12.0.1)

Hello everyone, I experience problems with the installation of the scripts and python runtime on Glyphs 3.0.4, running on my new MacBook Pro M1 Max (macOS Monterey 12.0.1).

I installed everything using the Plugin Manager.
The scripts are installed but do not appear. The scripts lay in the scripts folder.
I can’t chose a python version on the addons window.
Furthermore plug-ins like the Gauge Tool create problems and lead to the crash of the application, as a report says when I start Glyphs.

Did someone experience similar problems and found a solution?
Thanks in advance!

Can you update to the latest cutting edge version? Activate it in Preferences > Updates > Show Cutting edge versions.

Or install python from (version 3.0.4 supports python 3.10, for 3.0.3, you need to install 3.9). Then you need to install PyObjC by running this in terminal: pip3 install pyobjc

Thanks for your answer! Tried all of it. Unfortunately it still looks like that:

Bildschirmfoto 2021-12-15 um 10.03.01

Restart Glyphs?
Can you open the Repositories folder and delete the Glyphs Python folder. Then re-install it from the Plugin Manager. And wait 1–2 min. It needs to download some 100 MB. (I’ll add a progress bar.)

Thank you so much, it worked!

1 Like