Punctuation marks


I have exported my new font but when I use it in Adobe Xd and Microsoft Word, the punctuation marks are not appearing. I followed the comments about saving the font to the Fonts folder in the Adobe folders rather than opening the .otf through Font Book (although I did do this first) and it still hasn’t worked.

I need to fix this for my college project which is due in less than 2 weeks!


Are you sure you select the currently generated font in the apps? Try to rename the family and export with a new name, ABCTEST or something unique like that, and see if the punctuation is there.

I didn’t test it but I think XD is not using the Adobe Fonts folder. And Word for sure isn’t. If you see your font there at all, you have an old version without your punctuation installed. Delete it, export with a new name and restart all apps that use that font… repeat that for each iteration.

This script

works reliably for all my purposes. I don’t use Adobe/Microsoft apps, but most other apps on my Mac pick up the newly exported version without issues.

Thanks all! I deleted it and saved a new one and it seemed to work! I think it was because when I exported the font, I then opened the font up and installed it through Font Book (so effectively double installed it). When I saved the new one, I didn’t open it up through Font Book and it has worked.

1 Like