Python 3 and Speed Punk don't work

I tried to install Speed Punk, when I did that and restarted Glyphs, it told me that Speed Punk needs Phyton 3, and if I want to install it.I agree, but when I restart it tells me that the last time I started Glyphs, the plugins crashed (see picture)
Bildschirmfoto 2022-02-15 um 15.54.34

Im trapped in this circle and don’t know why it won’t work, please help. I currently have Glyphs 3.0.4. Thanks in advance!

Please remove all plugins from the Plugin and repositories folder. Then try if your python works by running this script:

print("Hallo")

If that prints without error, install the plugins again.

Thanks for the quick answer!
I tried it out, and as I expected it told me I need Phyton 3 and wether I want to download it (see picture).
Bildschirmfoto 2022-02-15 um 16.53.41

If i click download, nothing happens, neither when I restart. It seems to have a problem installing Phyton 3?

Update: I found the error, in my Plugin Manager there’s a warning sign next to Python (see picture).


I followed their advice, but in my Addons window when I try to select which Python version to use, there is literally nothing, empty space. Im redownloading Python and keep you updated if it works then!

Ok I managed to fix the problem now. I reinstalled Python 3 from the Plug In Manager, now it all works. Thanks!

1 Like

this means where to run the script?

What do you mean? What do you want to do?


how to solve this…

What do you want to solve? Are you having trouble getting Python to run with Glyphs?