QuickLookSatellite problem

I found 3 old ones - deleted them and keep my fingers crossed…

Here it goes again… please help with this pain in the neck. Thanks
QuickLookSatellite .zip (114.5 KB)

The crash happens when an icon is rendered by quicklook and then quicklook plugin crashes. But why it does this inside Glyphs is strange. Can you look around in Finder if you find a .glyphs file that has no “Ag” in the icon? That file might cause the crash. If you could send it to me?

I found 2 of them. here they are.__G.zip (130.7 KB)

Agin this pops up. And I checked - no .glyphs files that have no “Ag” in the icon found in the finder.

Now this pops up every few minutes. Any clue?

Can you send me the full crash report?

Now with Glyphs 3.03 I get the same error.

here is the text file.QuickLook error.zip (31.9 KB)

So, even after restart I tried to open Glyphs 3.01 app from the dock. An error message popped for a split second and vanished.

As I tried to open the last file with Glyphs 2.65 it wouldn’t let me…

All I can do now it open the OTF file I generated an hour ago and open it with the old version to continue working.

Any advice would be appreciated.

This crash do seem to be caused by the Unitizer plugin.
You can hold down the Option and Shift key when you start the app to disable plugins.

@Georg – The Unitizer plugin has been broken for some time. I am pretty sure I reported it but it never got fixed due to priorities. It needs updating for Py3.

Jun 25 17:23:14 server Glyphs 3[10661]: Unitizer has encountered a fatal error, and will now terminate.
Jun 25 17:23:14 server Glyphs 3[10661]: An uncaught exception was raised during execution of the main script:

SyntaxError: Missing parentheses in call to 'print'. Did you mean print("Unitizer plugin: Add your unitizerUnit custom parameter to your master")? (plugin.py, line 40)

This may mean that an unexpected error has occurred, or that you do not have all of the dependencies for this bundle.

Rainer and I have updated the plugin already but Pablo never merged our pull request. I changed the link in the plugin manager to my repo. So deinstall/install it to get the fixed version.

1 Like

I just tried it and it now works fine in 3.0.3. Thank you.

@Georg – I spoke too soon. G3.0.3 [3090] MacOS 10.13.6. The Unitizer plugin is still a problem.

  1. If Unitizer is enabled when I open a file and double-click on a glyph cell, G3 hangs, not responding.
  2. If I already have the file open when I activate Unitizer, G3 hangs, not responding.

This happens only on a file with Italic Angle set. In the Roman part of the family, in a separate file, Unitizer works fine. I’m sending a system hang (Forced Quit) report file to you at support.

Unitizer was obviously not intended to work with italic angles. It should be.

I can’t reproduce this. What version of Python do you use?

3.9.1 (Glyphs)

This window is popping up all the time when I use the latest Glyphs under Big Sur:

Screenshot 2021-07-31 at 11.16.18

The problem is that you probably have older versions of Glyphs around. And QuickLook is picking the quicklook plugin from any of them. So even if I fix a problem with the plugin, the old broken ones are still causing this.

You can check what version of the plugin is currently used by running this command in the Terminal:

qlmanage -m

If you don’t need that old version any more, delete it and run:

qlmanage -r

to reset quicklook.

Then run the first command again to see what version is used now. Repeat the steps until a good version is picked up.

If you can’t delete a version, you might be able to hide it by putting it in a folder (inside the Applications folder) and add that folder to the “Privacy” list in System Preferences > Spotlight settings.

Thanks I will try that now.

Thanks, I will also try it.