Quite serious bug involving .SALT

I have 2-masters, 5-instances file. In the bold master, I used “layer bracket trick” to create slightly lighter versions of some complex letters (a, g, e, s) for the 2 darkest weights.

But then I’ve created alternate versions (that don’t use bracket trick) of some of those letters and put them in the stylistic sets for testing purposes. When exported, font behaves live all the stylistic sets were turned on (but they aren’t). Original letters are not accessible anymore.

For comparison, I’ve created a stylistic set for an alternate version of a “pure” letter and it worked fine. So it means the bug is caused by the bracket trick.

can you send me the .glyphs file to support [at] glyphsapp [.] com?

The file I sent is probably a bit newer. I’ve made come changes I didn’t see, “g.salt” path direction needs to be corrected. But besides that, it’s all the same file that doesn’t work.

I’ve just tried naming the glyphs according to the manual: “g.ss01, s.ss02”, but no luck.

UPDATE: it had something to do with my bad layer naming. There was a clash between names “Bold [123]” and “Bold [123] alt”.

Problem solved. But the manual could be updated to be more specific about this. Because if you make bracketed layer copy and forget to rename it, there will be problems.