Quote mark issue

Hi there. I am new to glyphs, I have read and watched a number of tutorials, but am still stuck with an issue with the double and single quote marks

I am fixing up a font for a friend who designed it in FontLab. I opened up the OTFs in glyphs ( I know…) But since doing so the double quote marks (201c, 201d) and single quote marks (2018, 2019) do not work as they used to. When testing and using the font they face the wrong way.

Any idea what I’m doing wrong?

TIA!

Double-check the Indesign settings.

It happens in a variety of applications, Adobe, Microsoft and others.

This is probably a font cache problem. Read this please:
http://www.glyphsapp.com/tutorials/eliminating-font-cache-problems

Thanks for this. So would people who license the font or install it for the first time have to do this too?

Please read the tutorial:

[…] installing a font with the same name as a previously installed one can seriously mess up your font caches.

If you only install it once, it shouldn’t be a problem.

Still have the issue, even when testing online on the likes of - http://www.impallari.com/testing/
The issue still happens?

Can you send me the .glyphs file? support (at) (this website without www)

I had a look at your file, and it is missing the quotedbl. In the sidebar of Font view, right-click Categories > Punctuation > Other, pick quotedbl. The design for quotesingle is not ideal, should just be a straight (‘dumb’) quote.

I also suggest you select all glyphs, and run Glyph > Update Glyph Info, and remove the glyphOrder parameter from File > Font Info > Font > Custom Parameters.

Hi there. I tried those things, and exported the font again with a new name to stop any cache issues, and still tested it on a new laptop and the quote marks still face the wrong way?

Would it be ok if I sent you the files again. Hoping it’s just me being an idiot and missing something…But I did follow the instructions to the letter. Sorry to be a pain…

Send it again please.

Maybe simple typing key problem

'
single-left 「Option」+「[」


single-right 「Shift」+「Option」+「[」


double-left 「Option」+「@」


double-right「Shift」+「Option」+「@」

Sorry I forgot to post the solution back then. It has been a while but I think you are right. IIRC the quotes in the picture were simple straight quotes: "