Quotes not appearing when typing on Text preview window

Hi, people!

I’m here again, sorry… I’ve found a similar issue on this forum, but it didn’t solve my problem. As you can see below, I have the single and double quotation marks on my glyphs — they’re displayed on the glyphs window (also, on MacRoman and Windows 1252 lists.), but, they do not appear when I type them on the Text preview window.


All I got is a yellow blank space… Please, what I should do/create in order to solve this issue?

Thank you.

Well… I apparently have found the problem: I was just typing on the Mac keyboard using the quotation key right next to the Enter key and it didn’t work! I had to use the character preview in order to use those marks. That’s crazy for me…

So, please, how can I enable these quotation marks on my typeface to be typed with that regular Mac keyboard key, instead of always have to use the preview? I think it’s more complicated for an average person to use my typeface that way…

How did you type them? The yellow box might be a dead key placeholder. What happens if you double click them in font view?

That’s what I got when I type twice in font view. But that’s because I’ve just added quotedouble and quotesingle to my glyphs… I still have to create them. Previously, I was typing them using just the Mac keyboard.


I think without those glyphs it would be hard (or impossible) to type the quotation marks just using a regular keyboard, isn’t it?

Some software, depending on the app and language settings, will offer you to replace the straight quotes (aka ‘dumb’ quotes) with the appropriate curly quotes. On the Mac keyboard layouts, you can usually also type them directly.

Of course, for replacing one with the other, they all have to be in the font in the first place. That is why adding the straight quotes ‘fixed’ the issue for you.


Got it, @mekkablue! Thanks!

Thank you too, @GeorgSeifert.