Rekha Maker/Viewer

Is there a reason why Rekha Maker and Rekha Viewer would not match?
My Viewer is defaulting/stuck to the Latin Cap Height

What do you mean? Can you make a screenshot? You should be able to set any height.

I am just trying to export the file and I get a “Core” error:
“Filter unavailable.
The filter “Value: RekhaMaker” was referenced in the custom parameters, but is not installed.”

I have installed them from the plugin manager so not sure why I am getting this error

  1. RekhaViewer works for me. With the Rekha parameter in Font Info > Masters, I get the expected preview with View > Show Rekha:

  2. I could produce the RekhaMaker issue, and I think I fixed it. Please try again. (Best to uninstall and reinstall through Window > Plugin Manager.)

Make sure you use the latest cutting edge version (build 3100).

Yes, I think the update helped. I also realised the issue was because I was defining the custom parameter in the wrong master :confused: and then previewing it in the one that didn’t have it defined.

I also added the Headline Top/Bottom metrics which I hadnt earlier. Does this mean I don’t have to define shoulderHeight in the custom parameters anymore?

Is there a way to view the Rekha once I have exited the edit view of a glyph?
It would be helpful to be able to compare multiple letters side by side ideally with a black shirorekha or atleast a dark one.

The preview panel below shows it is an orange colour which is not very helpful

Do you prefer it to be as dark as the rest in preview? I just changed it, see if it works better for you. Quickest way to update the plug-in is to uninstall and reinstall it, then force quit and restart the app.

And I just fixed the drawing in inactive glyphs. There was some outdated code.

Works for me. Thank you for both the updates.
What a fantastic Christmas gift :slight_smile:

1 Like

Suddenly yesterday I started getting an error message every now and then saying
“There was an error in RekhaMaker’s filter() method when called through a Custom Parameter upon font export. Check your Macro window output.” I kept hitting Ok and it would reappear until it would go away.

After updating to it appears when I do anything in the edit view (sometimes even clicking inside it)
It’s not specific to any glyph and doesn’t stop the font from being exported. But it makes it very hard to work on the file
Screenshot 2022-01-02 at 15.20.09

I’ll have a look. You made sure you have the latest version?

Updated to 3.0.5 (3109) today but the problem had begun before the update.

The bug stopped once I selected the current instance option in the preview panel below.
It only happens when I select a particular instance to preview below

Can you send me a sample font that shows this behavior? One glyph would suffice.

Is there a way to disable the Rekha maker in components?
It’s creating a double headline on exporting as a font so conjuncts appear like this

You can use …; exclude: glyphname, glyphname, glyphname… at the end of the filter value.

When I try that I get the following error message on export. The font still exports after I hit ok but the masters with this custom parameter don’t have a Rekha across all the glyphs

Screenshot 2022-02-26 at 09.22.43

Also just wondering out loud, if that were to work will it take away both the Rekhas in the glyph? I still need for there to be one Rekha in it.

exclude: will prevent the filter to run on the listed glyphs.

What is in your Macro window? What exactly did you put in your filter value?

I put this as a pre-filter value
RekhaMaker; height:530.0; thickness:24.0; overshoot:10.0; exclude: tt_tta-deva,

The error in the macro panel repeatedly is "TypeError: keys must be integers or strings, not native_selector"

In this image, I would still need the top, longer headline to appear, the smaller one for the initial component is what I do not require.
If I exclude this glyph in the filter and lose both that would not be ideal but I suppose I can add a headline later. Ideally, it would be great if Rekha maker could be associated with the glyph Bbox and not the individual components

If there isn’t a way to solve this for now, would decomposing the components be the best possible solution? I don’t want to stop using Rekha maker