Replace feature —> change name of SS

Hello, hello!

I’m using the “replace feature” custom parameter for certain instances to have different stylistic sets.
Is it possible to change the name of the stylistic sets as well?
Now these changed features keep having the old names.

Any help is appreciated!
Thanks!

Still nothing?

Maybe a “No! Not possible!”.
Or a “Yes, kinda. But you have to write it yourself”.

None help whatsoever?

Sorry. I missed your first post.

That is not possible right now.

In the meantime, it should be possible to work with something a bit less flexible.
Following the spec you could add the name at the top of your feature, like this:

featureNames {
name "Extra Boring Sub";
};

sub B by B.ss03;

And then do the same thing within the Replace Feature custom parameter.

Sidenote: I am a bit confused about the usage of parantesis etc. in there. The syntax is not 100% the same as in the feature window. But why? Also look out for autocorrected quotation marks.

Remember that this workaround might cause problems if you have a name defined at the bottom of the feature window. So make sure to delete the info there before you try this.

1 Like

Hi all,
I’ve just tried doing this three years later and it’s not working for me.
My custom parameter Replace Feature looks like this:

ss01;
featureNames {
name "Renamed ss01 feature";
};
sub a by a.ss01;
[...]

But when I try to export the font, I get an error in ames. Without the featureNames{[...]} section it works.
Any idea what’s going on? I’m using the latest Glyphs 2 for this project.

This works for me.

What exact error do you get?

Can you send me the file?

Hi Georg,
The error I am getting is:

MakeOTF error
Error: “invalid token (text was “â”)” in Feature ames in line: 1

I’ve sent you the file to your support email. I’m using the latest Glyphs 2.
Thanks in advance!

Best,
Tamir

You have curly quotes in the replace feature parameter:
Screenshot

The third line needs to be:

name "Double-storey a";

Thanks, I oversaw that! I wonder how that happened, though.

Have you written the text somewhere else? Sometimes the automatic quotes are added by macOS.