Round Corners vs CP Filter Round Corners accuracy

In order to get a 100px corner, I need to enter a radius of 98 into the Round Corners. Likewise a 200px corner requires I enter a radius 196.

However if I copy the setting using the cog menu and add the Round Corners as a Custom Parameter Filter I get a different result. If I export an OTF the values are different. A CP value of 98 creates a 98px corner. Is this a bug?

It might have to do with the visual correction setting. It might not work in the CP.

It isn’t disabled when I apply it as a filter. With visual correction deselected, shouldn’t the result be the same as the radius entered? I’d expect some change in value if it was selected.

I’ve been using both the normal filter and the CP recently and I’m having to adjust the values to get what I want. For example applying a radius of 40 results in a corner of 41u. There’s something iffy going on with the accuracy of Glyphs, it isn’t as accurate as it should be. See my other post here Rounding errors when scaling when none should occur

Is visual correction enabled or disabled?

Sorry, I meant to say visual correction is disabled. In this case applying a value of 100 results in a corner radius of 102 u/em.

I’ll have to go back and have another go with the original font file to see if I can find the differences between the CP and applying the filter. It had a quick go at making a simple two glyph test file but I couldn’t recreate the differences this time.


  1. Open the attached file and go to the Plus glyph.
  2. Select all the points in the glyph (to apply to both inner and outer corners) and select Round Corners in the menu.
  3. Set Radius to 45 and Visual Corrections unchecked. Don’t click OK just yet.
  4. Using the Cog menu, Copy Custom Parameter.
  5. Now click OK to apply the filter.
  6. Measure the corners. Note they have a radius of 46 units.
  7. Undo the Round corners to return the outline to its original shape.
  8. Now go to Font Info > Instances and paste in the CP from your clipboard, giving a value of [Filter > RoundCorner;45;]
  9. Paste it a second time and change the value to [Filter > RoundCorner;-45;] so that the filter is also applied to the inner corners. Exit Font Info and return to the main window.
  10. Export the font as an OTF with settings Remove Overlap - checked, Autohint and Save as TTF - unchecked.
  11. Locate the newly created font file and open it in Glyphs.
  12. Double click to edit the Glyph and measure the corner radius. This time it is 45 units.

This also happens with other values. The two methods of appyling the filter create different results.

Here is the test file and the exported OTF.
Filter (3.8 KB)

I also tested this using only a single CP, in case doubling it up was causing the difference. It didn’t make a difference. It appears that the CP is applying the filter accurately but doing it from the menu command produces the wrong result.

Thanks for reporting, will have a look.