RoundCorner custom parameter not applied to corner components on export


Using latest Glyphs 3249 the RoundCorner; 18; 1; custom parameter is applied correctly in the Edit View (screenshot top) and the Preview Panel (screenshot bottom) across both the glyph and corner components.

Exporting the same shape in either TTF/OTF skips the rounding in corner components. Other paths get rounded as expected. What am I doing wrong?


Can you send me a sample font?

Hi @GeorgSeifert, thanks for the quick reply.

Sure, here’s a minimal reproduction file.

RoundCorner Test.glyphs (436.4 KB)

The Filter is only appleid to outside corners. This has nothing to do with the corner components (the bar of the H is not rounded, too). Add another Filter parameter with a negative radius to round the inside corners.

Thanks for the reply.

Why is the Preview Panel showing a different result than the exported file? Seems counterintuitive/buggy.

Naturally I don’t want to round the inside corners/counters, I want to round the outer serif components.

Attached below is a screenshot of the exported OTF result—the corner components get rounded, but the CC/stem connection is ignored.

If there was a way to make the filter ignore certain glyphs or components, I could make them rounded by hand, but the current result is a strange middle ground that I have little control over.

The attached screenshot demonstrates that you can exclude any glyph you want using the ‘exclude’ parameter (I, hereby excluding ‘.notdef’ glyph only). It also shows how different outer/inner roundness values are applied.

I see. The Preview looks indeed wrong. The corner has an open path and those are handled differently. When exporting, the filter is applied after the corner is included into the outline, when previewing, the corner is rounded before. To avoid that, add a “;exclude:_corner.flat” to your filter string.

Thank you both for the replies.

Last question: is there a way to “bake” the outlines and the corner components together before export so I basically get what I am seeing in the Preview Panel?

I have quite a lot of different corner components and so ideally I would like to automate the rounding as opposed to doing the ;exclude: hack and redrawing all of them by hand.


That is currently not possible. But there is another solution. You can draw another _corner.flatRound. Then use a “Rename Glyph” parameter.

I am not sure I follow.

You mean draw a separate _corner.flatRound that is rounded by hand and swap that via Rename Glyph for the _corner.flat on Export?

yes. I send you the file with the full setup.

1 Like