Running any script quits Glyphs

I have a trouble on using Python script in Glyphs.
When I run any script from plugin manager, my Glyphs gets quitted.

Moreover, I ran a very simple code using macro panel, it also quit.
If I restart the Glyphs, it says there was some error.
But I cannot find specific reason about this condition.

As I think, it’s about the installation of Python, not the contents of scripts.
Because the source code did not contain any content of Glyphs API.

I think I applied Python in correct way.
Is there any effective try that I can do?
I reinstalled the Glyphs and Python(in Glyphs plugin manager) so many times.

Or is there any way that I can use Glyphs API in external source code editor?


  1. Uninstalled Glyphs perfectly (with AppCleaner).
  2. Reinstalled Glyphs.
  3. Installed Python module in plugin manager.
  4. Apply it in Setting > AddOn.
  5. Ran very simple code.

Please remove the “Glyphs Python” from “~/Library/Application Support/Glyphs 3/Repositories” and install it again. It will take some time and sometimes gets corrupted when the installation was interrupted.

I tried it but it does not work.
When I install Python on menu ‘Script > Install Python Runtime’,
there is no reaction and I should install on plugin manager.

Can be this point relative to my problem?
I cannot suspect what the problem is…

Please help me… :frowning:

Please install from the Plugin Manager. After you manually removed it from the Repositories folder.