Scale to UPM issue

I’m getting Scale to UPM error while trying to export a font family (2 masters, 4 instances, all metrics are similar, UPM 1800, Ascender 1200, Descender -600). The Scale to UPM is set to “1000” and the error I’m getting is “bad FontMatrix”.
Any ideas how to fix that?

What version do you have. I fixed several things in the latest betas (965). If you still have the problems in that version, please send me the file.

Version 2.4.1 (965)

what is the email, Georg?
disregard question about the email - found it.
will email in a moment

The file you send me exports fine.

Can you post the actual error message.

The file exports fine because there is no Scale to UPM set. I deleted it because it didn’t work and changed the metrics back to normal. I’ll email previous version momentarily.

Here is what I tried to fix:
setting UPM to 1800 and exporting without scaling - works
setting UPM to 1800 and adding a “fake” scaling to 1800 - works
but 1800 to 1000 - doesn’t work :frowning:

I am having the same issue; I didn’t realize it was required to make the change to the scaling factor field first; a whole batch of files took the new em size (2048) but did nothing to outlines. It seems like reversing the process (scale back to 1000) and then following the correct order of steps solves it, but sometimes not. Could this be either two completely separate, non-dependent features, or combined into one that does not fail if the order is wrong?

1 Like

There are two very distinct functions. When you change the value in the UPM field, nothing else is supposed to change. This is useful to change the size of the font in use (bigger UPM means smaller letters). When you use the “Scale UPM” dialog, the appearance of the font will be the same but all values in the font will change.

so a very typical use case is to play around with the UPM value, export the font, check the size in relation to other font, until you are happy. Then as a last step, maybe, use the “Scale UPM” to go back to a UPM of 1000. Other than that, don’t use the Scale.

1 Like

Since the last Glyphs update, the custom parameters “Scale to UPM” doesn’t work anymore. Any other feedbacks on this issue?

For VAR export it looks fine.

1 Like

Fixed it.


Thank you, Georg, for fixing it in the latest release :cowboy_hat_face: